Maven project failed to build

 

Questions


I am new to Maven projects. I imported an existing Maven project to eclipse, then made a new configuration. I tried running the application then but the console shows

[ERROR] Failed to execute goal com.google.appengine:appengine-maven-plugin:1.9.4:devserver (default-cli) on project helloworld: The plugin com.google.appengine:appengine-maven-plugin:1.9.4 requires Maven version 3.1.0 -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginIncompatibleException

I checked the link it showed. It suggested to update the build environment to the required Maven version. I searched for it but found out to make certain changes in pom.xml. But nothing worked. Can anyone tell me how to resolve the problem. My installed Maven version is 3.0.5.

 

 

————————————————-

Answer

In order to execute this plugin, you need maven version 3.1.0 at least. Install it from here (http://maven.apache.org/download.cgi) and after that check if it is correctly installed by executing following command in the command line:

mvn -version

eclipse,google-app-engine,java,maven,maven-3

Facebook Comments

Post a comment